View Single Post
  #9  
Old June 21st 18, 11:05 PM posted to alt.sys.pc-clone.dell
Ben Myers[_4_]
external usenet poster
 
Posts: 468
Default Bios settings / adding 2nd HD to a T3500

On Thursday, June 21, 2018 at 1:30:40 PM UTC-4, Richard Kopp wrote:
Hello William,

Many years after you solved this problem for Bill, I have a similar configuration and can't seem to resolve it. I have a refurbished Dell Precision T3500 running Windows 7 and I am trying to add a Toshiba X300 4TB drive as a second drive. There are no instructions from Toshiba, so I am trying the directions that you have given but no success yet. I have not been able to get the drive detected by the OS. The Bios setting are just RAID and just SAT 0 and SATA 1. Can you think of another fix for this? I hope you're still monitoring these groups.

Rick Kopp

On Monday, February 14, 2011 at 11:19:28 AM UTC-7, William R. Walsh wrote:
Hi!

Even though I ordered the "non-raid" configuration from Dell, the "sata
operation" section of the system bios (A08) has the "Raid on" option
set, even though there is currently only 1 hard drive. *There are two
other options avialable: *"raid autodetect / ahci" and "raid autodetect
/ ata".


The settings break down as follows:

RAID Autodetect / AHCI sets the SATA controller up so that it operates
in the AHCI mode (allowing your software to take advantage of special
serial ATA features, such as native command queuing) if there are
normal hard drives attached. However, if the drives have a "signature"
written to them, the SATA controller will operate as a "fake RAID"
device automatically.

RAID Autodetect / ATA sets up the SATA controller so that it operates
as though it were a conventional parallel ATA controller. This is used
for older operating systems that don't understand or have driver
support available for the SATA controller in your system. Now I
haven't verified this, but if a set of "signed" drives are detected,
the RAID option probably also provides for limited disk access
services for older operating systems as well. You lose the advantages
specific to SATA drives, but the system will at least run an operating
system that has no specific support for SATA/AHCI.

If your drives aren't signed (meaning they haven't been configured in
a RAID set), the RAID On setting has no effect. It's probably only
turned on so those who want to create an array can do so easily.

You would set up a RAID array using the Intel Matrix storage manager
utility. I don't believe the Intel Storage BIOS has a configuration
utility.

Also, I get a warning that changing these bios settings may make
the system unable to boot and would need to reinstall the OS.


You get this warning because some versions of Windows are reliant upon
having an installed driver to talk to the SATA controller and your
disks. If you choose the AHCI mode or have a configured RAID set,
you'll need a special driver. Windows XP and earlier must have this
driver installed (by way of the F6 key prompt that shows up when you
start Windows setup). Windows Vista and later have built in support
for AHCI and "RAID" on all popular SATA controllers.

As it is, you should be able to connect your new drive, turn on the
SATA port in system setup and then prepare it for use as you normally
would.

William


Given the age of the system, I have to wonder whether its BIOS can support a 4TB drive. I have a T3500 here with an SSD primary/boot drive and a 2GB secondary drive. They work just fine, of course.

I do not know for sure, but for years and years, there have been various technical limitations imposed by a BIOS designed and written with little foresight... Ben Myers